Use if the "Repel" option

I am running this code:
result.pca = pca (X = data, ncomp = 3, center = TRUE, scale = TRUE)
pdf (“PCA-individuals-plot.pdf”, width = 15, height = 15)
plotIndiv (result.pca, comp = c(1, 2), ind.names = TRUE, group = metadata$group, = colors, legend = TRUE, title = “PCA on individuals”, legend.title = “Groups”, cex = 4, geom_text_repel = TRUE) ()

But I am not able to repel the individual labels. I have tried with the following:

geom_text_repel = TRUE
repel = TRUE
ind.names.repel = TRUE

But nothing works. I am using Mixomics v 6.16.3 on R v 4.1.1.
Any suggestion? Thanks in advance!


hi @Moroldo ,

While we use ggplot2 inside the plot function, we do not take additional arguments from ggplot2, apart from those listed in ?plotIndiv.

If the sample labels is not appearing correctly, make sure your row names in data are correct!


Thanks Kim-Anh,

In fact, there is a topic on the forum stating that, after installing a specific “custom” function, it should then be possible to use the “repel” option within the “plotindiv” function. I have tried this, but in fact it does not work and, what’s worst, it makes completely disappear the names of the samples. I don’t know what happens, but possibly that topic should be deleted or modified, because it could pose problems for other users. Thanks and have a nice day,


Yes Al proposed to download a variant of the package on gitHub, but this has not been implemented in the current mixOmics version.


Thanks again Kim-Anh!