plotIndiv () consensus block ellipse error

I was trying to use the plotInv to get the consensus plot in the diablo analysis. It worked well without the ellipse, but when I added the “ellipse=T”,

  •       blocks = 'consensus',
  •       legend = T,
  •       ellipse = T)

it gave me the warning messages:
Warning messages:
1: In [<-.factor(*tmp*, df.ellipse$Block == “Block: weighted.consensus”, :
invalid factor level, NA generated
2: In [<-.factor(*tmp*, df.ellipse$Block == “Block: consensus”, :
invalid factor level, NA generated
This produced separated plots1
Many thanks,

I tried it in windows and it works fine.
I have no idea why this happens.

Hi @martina,

Thanks for reporting this issue.

I can see that when trying to create a consensus plot with ellipse = TRUE, you get strange results, but not on Windows.

Can you please confirm your mixOmics versions on both machines are at least 6.11.21, and that you can have created the MyResults.diablo object using updated versions (as opposed to loaded from previous runs).

This should go away if the the above is followed, otherwise please let me know.



Thank you for your answer. Although mixOmics is 6.13.0 on both machines, R on my mac is version 3.6.0 . I updated the R and reinstalled the mixOmics. Problem solved.
Thank you very much!

1 Like